漏洞简述
2020年09月03日,360CERT监测发现 phpStudy 发布了 phpStudy 安全配置错误漏洞 的风险通告 ,漏洞等级: 高危 ,漏洞评分: 7.6 。

phpStudy 存在 nginx 解析漏洞,攻击者能够利用上传功能,将包含恶意代码的合法文件类型上传至服务器,从而造成任意代码执行的影响。
该漏洞仅存在于phpStudy Windows版,Linux版不受影响。
对此,360CERT建议广大用户及时将 phpstudy 升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

影响版本
phpstudy:phpstudy : <=8.1.0.7
漏洞详情
安全配置错误漏洞

漏洞产生的原因为

1、由于用户的错误配置导致 nginx 把以 .php 结尾的文件交给 fastcgi 处理,为此可以构造 http://www.xxx.com/test.gif/xx.php (任何服务器端不存在的php文件均可,比如a.php)

2、但是 fastcgi 在处理 xx.php 文件时发现文件并不存在,这时 php.ini 配置文件中 cgi.fix_pathinfo=1 发挥作用,这项配置用于修复路径,如果当前路径不存在则采用上层路径。为此这里交由 fastcgi 处理的文件就变成了 /test.gif 。

3、 最重要的一点是 php-fpm.conf 中的 security.limit_extensions 配置项限制了 fastcgi 解析文件的类型(即指定什么类型的文件当做代码解析),此项设置为空的时候才允许 fastcgi 将 .png 等文件当做代码解析。

简单来说就是当你访问一个不存在路径的时候 会解析你上一层目录的文件当做代码解析 所以我们插入1.jpg的代码(phpinfo)会被执行

漏洞利用情况如下:

34436-cfu0ykci06.png

1.jpg内容如下

12929-uo0sur36p9a.png

成功解析了1.jpg里面的内容


本文由 wulaoban 创作,采用 知识共享署名 3.0,可自由转载、引用,但需署名作者且注明文章出处。

还不快抢沙发

添加新评论